首页 > 技巧 > 阿里云虚拟主机创建wordpress博客
2018
08-14

阿里云虚拟主机创建wordpress博客

几年前曾经做过一个独立博客,用的是免费主机,后来因为工作忙,没时间打理,也就放弃了,最近忽然又来了兴趣,想要做个站看看这次能坚持多久吧

在主机的选择上,首先免费主机不会再考虑了,毕竟有过经历,一是不太稳定,另一个也许是免费的所以就不太珍惜吧,所以要找个靠谱的价格又能接受的,在阿里云、百度云、腾讯云、华为云等一系列叫的上名字的大公司看了一圈,一个字,贵啊。各种云服务器啊,云数据库啊,一看名字就各种高大上,看的我眼花缭乱,时代进步的这么快吗,真是不懂啊,选来选去各家产品里阿里云的虚拟主机是最便宜的一种了。而且当年就是用的虚拟主机,这个熟悉啊,虽然和那些比起来有好像那么一点点LOW。

注册购买我就不用说了,有过网购经验的都懂,实在不会问女票吧

阿里云入口地址点击进入

阿里云虚拟主机创建wordpress博客 - 第1张  | 冰美娜盟

比如下边这个

阿里云虚拟主机创建wordpress博客 - 第2张  | 冰美娜盟

好,还是说回搭建wordpress吧,主机的控制台样式如下;

阿里云虚拟主机创建wordpress博客 - 第3张  | 冰美娜盟

第一步:

将wordpress的安装程序通过FTP上传到根目录的htdocs文件夹中

wordpress的安装程序下载链接

FTP程序下载链接

第二步:

在浏览器输入你绑定的域名或者你的FTP登录主机地址(临时域名)后会进入wordpress的安装向导

阿里云虚拟主机创建wordpress博客 - 第4张  | 冰美娜盟

点击现在就开始。这时候我们看到如下页面

阿里云虚拟主机创建wordpress博客 - 第5张  | 冰美娜盟

这些信息在主机的控制台,注意一点就是数据库主机一栏要填写数据库连接地址。写好后点提交

很大机率出现internal server error的报错这种情况

阿里云虚拟主机创建wordpress博客 - 第6张  | 冰美娜盟

这主要因为服务器配置问题,阿里云默认的PHP5.2版本不兼容最新版本的WordPress系统导致500提示!!!

需要到控制面板里将php版本修改为php5.4以上,推荐php5.5.保存即可解决安装故障。如果数据库提示无法连接,可以在控制面板里重置数据库密码,注意加密模式要选择41位!

阿里云虚拟主机创建wordpress博客 - 第7张  | 冰美娜盟

 

阿里云虚拟主机创建wordpress博客 - 第8张  | 冰美娜盟

然后就到下面的界面,恭喜你,世界又多了一个WordPress的WP粉。阿里云虚拟主机创建wordpress博客 - 第9张  | 冰美娜盟

到这一步,基本上就意味着大功告成了,因为后边基本不会出错啦。

点击进行安装按钮。下一步—-下一步就好了

阿里云虚拟主机创建wordpress博客 - 第10张  | 冰美娜盟

最后编辑:
作者:盟叔的黄瓜
我就是我,不一样的烟火
捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!

留下一个回复

你的email不会被公开。